T-Mobile APN for MMS Nexus One

sportsfreak2159

New member
HoFo Member
Joined
Aug 20, 2006
Messages
724
Carrier(s)
AT&T
Device(s)
iPhone3GS 16GB Black
Hey,

I searched the forum but could not find a solution. I use the 10/month data plan and use the internet2.voicestream.com apn for data. The problem is, I can't send MMS. I receive MMS just fine, but cant seem to send them. Does anyone know what APN to use/ what ports if needed. Below are all my APNs

T-Mobile US
apn: internet2.voicestream.com
mcc: 310
mnc: 260
apn type: defualt

T-Mobile US-MMS
apn: wap.voicestream.com (when I use epc.tmobile.com it says i need to upgrade)
mcc: 310
mnc: 260
apn type: mms

any help is appreciated.
 
I use Internet3 on my N1 but my settings should help. I'm using two APNs to get the job done.

APN 1 (set as default with green dot): Internet3
Name: Internet3
APN: internet3.voicestream.com
Proxy: <Not set>
Username: <Not set>
Password: <Not set>
Server: <Not set>
MMSC: <Not set>
MMS Proxy: <Not set>
MMS Port: <Not set>
MMC: 310
MNC: 260
Auth Type: <Not set>
APN type: default, supl

APN2 T-Mobile US (secondary - this is the MMS one):
Name: T-Mobile US
APN: epc.tmobile.com
Proxy: <Not set>
Port: <Not set>
Username: <Not set>
Password: <Not set>
Server: <Not set>
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMS proxy: <Not set>
MMS port: <Not set>
MMC: 310
MNC: 260
Auth Type: <Not set>
APN type: MMS

Hope that helps :)
 
The nexus one default apn is set to epc. A difference between your setting and the default I use is that my apn type is listed as not set where yours is default or mms. Second, you need to add an mmsc. See the second post for that address.
 
Back
Top